OA Support Services
Incident Report for Order of the Arrow
Resolved
The issue has been resolved.
Posted Jun 24, 2020 - 11:49 EDT
Investigating
We are currently investigating a service failure impacting the availability of all support services. We will provide an update as soon as possible.
Posted Jun 24, 2020 - 08:39 EDT
This incident affected: OA Support (JIRA, Confluence).